× This forum is read only. As of July 23, 2019, the UserSpice forums have been closed. To receive support, please join our Discord by clicking here. Thank you!

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Database connection unsuccessful
#1
1) On initial setup page everything else is green, except Display Errors: OFF. 

    How do I turn this on?

2) When I click on "Test Settings" after putting all my database info in, it comes back saying 
Database connection unsuccessful! Please try again. I created a blank database on AWS RDS and I have connected successfully to the database using Mysql Workbench. 

THanks
  Reply
#2
You have to turn on error reporting on your php.ini file.  You set it to E_ALL.  If you scroll down, it's described where to make the change. Some systems have multiple php.ini files, so if you want to make sure you have the right one, create a new php file like test.php

put
<?php 
$ini = php_ini_loaded_file();
echo $ini;


Then run that file and it will give you the path of the file to edit. 

Regarding the inability to access the db. That's a little weird if you can use it from an application.

A few things.  If you use a random IP address on mysql workbench, try putting 127.0.0.1 for your ip.  If you already had 127.0.0.1, try putting localhost or the actual IP of the server.  

Let me know if you need more things to try.
  Reply
#3
(12-13-2018, 11:24 PM)mudmin Wrote: Thanks,

I tried to upload UserSpice to one of my HostGator accounts, and created a blank database like one of your tutorials. I put 127.0.0.1 as the host, and I get unsuccessful. I also tried localhost. Can you tell me what files should get updated, so I can see if they are updated. Maybe the files don't have the correct permissions.


You have to turn on error reporting on your php.ini file.  You set it to E_ALL.  If you scroll down, it's described where to make the change. Some systems have multiple php.ini files, so if you want to make sure you have the right one, create a new php file like test.php

put
<?php 
$ini = php_ini_loaded_file();
echo $ini;


Then run that file and it will give you the path of the file to edit. 

Regarding the inability to access the db. That's a little weird if you can use it from an application.

A few things.  If you use a random IP address on mysql workbench, try putting 127.0.0.1 for your ip.  If you already had 127.0.0.1, try putting localhost or the actual IP of the server.  

Let me know if you need more things to try.
  Reply
#4
I downloaded UserSpice4400beta1 version, and I was able to get it to work.

Thanks,
  Reply
#5
Ok. That's very weird. What version were you using the first time?
  Reply
#6
(12-15-2018, 09:15 PM)mudmin Wrote: Ok. That's very weird. What version were you using the first time?

I originally used the one in github.

https://github.com/mudmin/UserSpice4
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)