× This forum is read only. As of July 23, 2019, the UserSpice forums have been closed. To receive support, please join our Discord by clicking here. Thank you!

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Contribute for Language Pack
#1
Lightbulb 
I am planning to add BD_bn language to my userspice. But I can you add thia language pack to  updates please? If yes tell me how.
  Reply
#2
(04-18-2019, 03:37 PM)MerajBD Wrote: I am planning to add BD_bn language to my userspice. But I can you add thia language pack to  updates please? If yes tell me how.

Sure.  Just  paste the contents of the language file on pastebin.com and share the link here. Thank you!
  Reply
#3
Here is the language pack: https://pastebin.com/3rheAxf4
Whats next? Do I need to translate other files, e.g. : admin_dashboard?
Last question, how to implement this file?
I've copied thos file to /users/lang/ and userc/lang
I've copied the flag image to /users/lang/flags in iso format
Then I tried to change language from admin dashboard, didn't work, then tried to change from user account, didn't appeared the language, then I replaced the en-US file im /userc folder and got success. But the last method I tried Isn't a right way to do.
  Reply
#4
The right way to do it is to copy that file as bn-BD.php to users/lang and the flag to the flags directory, but I'm seeing the same thing that you are seeing. I was just having a conversation with Usamusa one of our other developers about this sort of thing, and I think it is a browser issue that we will need to correct in the head tags file or something like that. My guess is that something in our head tags is conflicting with the character set. Do you know the name of the character set for bn?
  Reply
#5
(04-19-2019, 11:43 AM)mudmin Wrote: The right way to do it is to copy that file as bn-BD.php to users/lang and the flag to the flags directory, but I'm seeing the same thing that you are seeing. I was just having a conversation with Usamusa one of our other developers about this sort of thing, and I think it is a browser issue that we will need to correct in the head tags file or something like that. My guess is that something in our head tags is conflicting with the character set.  Do you know the name of the character set for bn?

Oops. Nevermind. I got it to work Smile
https://i.imgur.com/vP8FPxp.png

Let me just post the whole language directory. Nothing in usersc. Just overwrite everything in your users/lang.  I attached lang.zip to this post.


Attached Files
.zip   lang.zip (Size: 105.14 KB / Downloads: 1)
  Reply
#6
same thing for me. When I restarted browser, it worked.
And the reason language was not showing on user setting is the flag need to be in png format. I uploaded in jpg. After I corrected, It worked.

The zip file seems like corrupted.. Can you attache in other format please?
  Reply
#7
Ahh. I am not near my computer but I will when I get back
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)