• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Migrate to live server
#1
i developed my userspice page on a xampp, now im ready and i want to migrate to a live webserver running ubuntu and apache

i copied all files into the webroot and copied the database with phpmyadmin, and changed init.php to have sufficent sql credentials. but its not working it shows a blank page.

is there more to do to migrate to other server?
i could not find any information about moving a install.

  Reply
#2
(04-30-2017, 07:14 AM)chwzr Wrote: i developed my userspice page on a xampp, now im ready and i want to migrate to a live webserver running ubuntu and apache

i copied all files into the webroot and copied the database with phpmyadmin, and changed init.php  to have sufficent sql credentials. but its not working it shows a blank page.

is there more to do to migrate to other server?
i could not find any information about moving a install.

Did you ever get an answer to this? I am also interested to know how I can move a project I had been developing locally to the server
  Reply
#3
Sorry. I missed this. You shouldn't HAVE to do anything. I copy projects all over the place without any issues. UserSpice doesn't tend to care what folder it's in.

Now if you're moving to Ubuntu, the issue you might have is capitialization. Linux cares about character case in both the db and folders, and that could definitely be breaking something.

If you're just getting a blank page, you'll have to go into the proper php.ini and turn on error reporting to E_ALL.
If you just make a blank test.php page on your server and put
<?php phpinfo();
in that file and run it, somewhere near the top it will give you the path to the php.ini file it's looking at.
  Reply
#4
(12-05-2018, 01:25 PM)mudmin Wrote: Sorry. I missed this. You shouldn't HAVE to do anything. I copy projects all over the place without any issues.  UserSpice doesn't tend to care what folder it's in.

Now if you're moving to Ubuntu, the issue you might have is capitialization.  Linux cares about character case in both the db and folders, and that could definitely be breaking something.  

If you're just getting a blank page, you'll have to go into the proper php.ini and turn on error reporting to E_ALL.
If you just make a blank test.php page on your server and put
<?php phpinfo();
in that file and run it, somewhere near the top it will give you the path to the php.ini file it's looking at.

I am still getting a blank page. Here is the messgae displayed:

This page isn’t working
www.[domain name] is currently unable to handle this request.
HTTP ERROR 500

What could be the issue here?

NB: I am running the local version of the project on  XAMPP and it is running well
  Reply
#5
I will shoot you an email. Error 500 is a generic message that the server posts when PHP error reporting is turned off.

I don't know much about your server, but if it's some sort of vps or something that happens when the files you copied to the server are not "owned" by the apache user (usually www-data).

So you would SSH in and do something like
sudo chown -R www-data:www-data /var/www

If you created a file like I said above with just those two lines, then the ownership is almost certainly the problem. If not, then turning on error reporting in php.ini will give you more of a clue.

Like I said, I'll email you.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)