× This forum is read only. As of July 23, 2019, the UserSpice forums have been closed. To receive support, please join our Discord by clicking here. Thank you!

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New Install issue using Docker
#1
Hi, I successfully setup userspice about 1 weeks ago using AWS. Today I'm trying to setup on my local machine using Docker. Downloading the source, I notice a new version but that may not be the problem.

When I go through the installer I get to step 2 (Database Config) and enter my connection details. No matter what I do I keep getting this error "Database connection unsuccessful! Please try again."

I've tried localhost; 127.0.0.1; both with and without port 3306
I know my DB is working because MySQL Workbench will connect with no issues.

The permissions to users/init.php is 666 but I suspect it can't be written to because the file ends with:

require_once $abs_us_root.$us_url_root.'users/helpers/helpers.php';

// Set config
$GLOBALS['config'] = array(
'mysql' => array(


Rather incomplete looking.

Any help would be appreciated.
Jeff
  Reply
#2
You didn't run install/install.php or if you had previously-your init.php file is one from an uninstalled version.
  Reply
#3
Thanks for the replay,

I downloaded the ZIP again (4.3 from the home page) and there is no install/install.php There is and install/index.php which seems to be running the install wizard just fine.

Also the users/init.php is incomplete as previously mentioned. I suspect the install wizard is supposed to complete this but I'm having troubles.

Can you offer any other suggestions?
  Reply
#4
It uses fwrite I think-that might be an Apache/PHP module that could be disabled on your server. What kind of server? Control Panel?
  Reply
#5
You can also just add your credentials to this one and overwrite the partial one that's there. Then delete the install folder
Just host/dbname/username/pw
https://pastebin.com/gpCUt7VJ
  Reply
#6
Awesome! I'll give this a try and report back if I run into issues. I suspect not Wink

Thank you!
  Reply
#7
I also am using docker. However, on my dev machine I am using docker for windows. I was able to get the install wizard to work by using the docker IP for my database container rather than my host ip.

Let me know if that doesn't make sense and I will try to explain it better.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)