× This forum is read only. As of July 23, 2019, the UserSpice forums have been closed. To receive support, please join our Discord by clicking here. Thank you!

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
redirect loop on login
#1
Hello,

I have copied the contents of users to usersc directory and I'm working in there. Since that I can't login with not admin users, I get a loop between index.php and account.php, as long as cookies are set, that means I can't go back to the login screen before I delete the cookies. I have done some screenshots.

[Image: 2018-03-28_123757.png]

[Image: 2018-03-28_123851.png]

[Image: 2018-03-28_123905.png]

This is the working query:
[Image: well.png]

regards
  Reply
#2
login.php is either:
-not in your DB
-in your DB as private

You need to run this query:
Code:
SELECT * FROM pages WHERE page = 'usersc/login.php'

If there is a result, run this:
Code:
UPDATE pages SET private=0 WHERE page = 'usersc/login.php'

If there is no result run this:
Code:
INSERT INTO pages VALUES (NULL,'usersc/login.php',0,'Login',0,NOW(),NULL

So you're aware of what is happening:
usersc/login.php doesn't exist or exists and is private so it's pushing you to users/account.php
users/account.php is set to private and you aren't logged in, so it's redirecting you to users/login.php which in turn redirects you to usersc/login.php but then puts you in an endless loop.
  Reply
#3
that worked, thanks.
  Reply
#4
Hello,

I have the exact same problem again, but this time login.php and account.php private values are set to 0 and they exist in the DB and as file.
The loop is like this:
login.php ->302
account.php ->302
account.php ->302
index.php ->302
account.php ->302
account.php ->302

what else can be the problem?

regards
  Reply
#5
I have solved it. The account.php was set to private(regardless of what I said), my mistake.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)