× This forum is read only. As of July 23, 2019, the UserSpice forums have been closed. To receive support, please join our Discord by clicking here. Thank you!

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New Install - No Joy
#1
Just watched 2+ hours of vids on YT and am anxious to see what US can do, but...
I just installed the 4.3 version downloaded from userspice and am unable to login.
Had no idea what the default admin login would be, but I found on another post that it is "admin" and "password".
Looked in the db and sure enough the username is "admin", of course the password is hashed.
However, if it is "password" it does not work.
  Reply
#2
Ok, so I figured while I waited for a reply I would just hack my way in. So I tried a couple old tricks, neither worked. First thought I'd just modify the password with my own using phpymadmin's md5 function. But I searched the code and found you aren't md5ing the pass, it's bcrypt so that's a no go.

Then i figured i'd just comment out the login portion that encrypts the pass, create a new user, then give myself admin privs in the db.

Well, turns out the signup page does not work. If you attempt to create a new user you simply get a notice saying:

There was an error with your form. Please go back and try again. Please note that submitting the form by refreshing the page will cause an error.

If this continues to happen, please contact the administrator.

which is the same exact notice you get when trying to login using "admin" and "password".

BTW, when attempting to login you also get the notice:
Notice: Undefined property: stdClass::$registration in C:\xampp\htdocs\test.local\users\helpers\menus.php on line 64

missed it the first time cause it's very lightly colored and camouflaged against the background.

FWIW I'd say the 4.3 release is broke.
  Reply
#3
Well I've been working on this since around 6PM tonight - it's now 1:30AM.

Installed 4.3, listed the results above, deleted everything and did a complete reinstall. Same exact outcome. So I figured I'd try other releases, working backwards till one worked.

Installed 4.2. I get
Parse error: syntax error, unexpected '=>' (T_DOUBLE_ARROW) in C:\xampp\htdocs\test.local\users\join.php on line 37
and am unable to login or create an account. Scrapped that one.

Installed 3.2. Can't login get "Token doesn't match!". Tried numerous times, same result.

The htdocs folder of my dev server has 106 websites in it that I have built and work on for clients.
These UserSpice sites are the only sites that will not run.

Sadly, after 6 hours of attempting to forge this into a usable state, I'm giving up and moving on.
  Reply
#4
Can you run this query and let me know the output:
Code:
SELECT * FROM updates
  Reply
#5
Found an old core 2 dua and decided to setup a linux test server to see if that made any difference. Installed Ubuntu 16.4 with PHP 5.6 and VIOLA - I'm in!!

FWIW I did still see the message at login:
Notice: Undefined property: stdClass::$registration in C:\xampp\htdocs\test.local\users\helpers\menus.php on line 64

But I am thrilled to actually be able to see the admin screen and start toying with what US can do.

Also, not sure if you're aware, but in the Security Log there are four events listed, going back to 2017-10-09. Not sure if you left them there for demo purposes or not, just thought I'd let you know.


  Reply
#6
This is definitely because you're not hitting the update.php page after installation. That is a big problem given the updates are required to stabilize the system.
  Reply
#7
I captured screenshots of the install this time in case there were issues. I can send them to you if its helpful.

I can tell you that there was info displayed at the end of the install that says:
Applied update #####
Patched vericode vulnerability
followed by 8 more Applied updates

along with:
Notice: Undefined property: stdClass::$registration in /var/www/test.local/public_html/users/helpers/menus.php on line 64
  Reply
#8
Okay-once you navigated away from the update.php page and loggedi n, was the undefined registration gone?
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)