× This forum is read only. As of July 23, 2019, the UserSpice forums have been closed. To receive support, please join our Discord by clicking here. Thank you!

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
US v4.3.19 CLOAKING
#1
I was trying several times to CLOAK with the new version, I've change to YES in admin_user into MISC "Is allowed to cloak?" and even UPDATING and trying back or quitting and starting again doesn't work. Or I do something wrong maybe.
db says that user is '1' in cloak column.
  Reply
#2
There are a few rules about cloaking:
-you can't cloak yourself
-you can't cloak into UID 1 (I'm pretty sure)
-you can't cloak into the master array if you're not in the master array
-you can't cloak if allowed_cloak (or whatever the column is called)==0

You must set your user account to "Is Allowed to Cloak" from admin_user.php.

Can you confirm all of the above conditions are met?
  Reply
#3
Hi Brandin, I'm not sure if I understand you 100%. I'm the admin, I have several users with different levels, from plain user to a bit more, but under Admin, they all are marked with
Code:
allowed_cloak
and phpmyadmin says on that column ==1, but don't know what means the others conditions.
UID1 means admin ? Yo mean me as an admin I can't cloak others ? (of course not to myself).

In addition when I switch the
Code:
<select>Is allow to cloak</select>
anyways from allow->not allow and viceversa the green confirmation message says:
- Last Name Updated
- Set user cloaking to 1.

And from that modal one can't even see
Code:
lastname
and not, I didn't touch it before.

Don't know if that is a clue for you.
  Reply
#4
You need to set yourself to say allowed_cloak=1. Putting allowed_cloak=1 for other users means if they were to have access to admin_user.php they could cloak other users. And the criteria I listed above is the criteria around cloaking into-so another person cannot cloak into UID 1, not that reverse.
  Reply
#5
Got it! I did what you said and everything is working fine now.

Sorry but in my head could't think Admin should be switched to Cloak=yes.

Anyways, now is solved !

Thanks again dude.
  Reply
#6
Glad you were able to get it working Smile
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)