The following warnings occurred:
Warning [2] Undefined variable $unreadreports - Line: 26 - File: global.php(961) : eval()'d code PHP 8.1.2-1ubuntu2.18 (Linux)
File Line Function
/global.php(961) : eval()'d code 26 errorHandler->error
/global.php 961 eval
/showthread.php 28 require_once

× This forum is read only. As of July 23, 2019, the UserSpice forums have been closed. To receive support, please join our Discord by clicking here. Thank you!

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dropbox & Composer help
Hi All,

I have just upgraded my Userspice to the latest version after being many version behind. I have got most of my site working but appear to be having an issue with on part. I currently have a process that uploads a file to Dropbox - this is based on the following guide / files

For some reason with the update this script has stopped working and I can't figure out why. Can anyone help? The file gets created but does not upload and stops at the creation step. It worked perfectly in my previous version.

Looking through my code I have attached the point at which I think it stops if anyone can see anything obvious.

$file = "post/$filename.csv";

file_put_contents($file, $csv);
chmod($file, 0777);

require __DIR__ . '/vendor/autoload.php';
use Kunnu\Dropbox\Dropbox;
use Kunnu\Dropbox\DropboxApp;
use Kunnu\Dropbox\DropboxFile;
use Kunnu\Dropbox\Exceptions\DropboxClientException;

//Configure Dropbox Application

//Configure Dropbox service

$pathToLocalFile = __DIR__ . "/post/$filename.csv";
$dropbox = new Dropbox($app);

$dropboxFile = new DropboxFile($pathToLocalFile);
$file = $dropbox->upload($dropboxFile, "/apps/clickanddrop/$filename.csv", ['autorename' => true]);

//Uploaded File
<div id="page-wrapper">
<div class="container-fluid">
<div class="row">
<div class="col-sm-12">
<h1>Shipping File Upload</h1>
<!-- Content Goes Here. Class width can be adjusted -->
              <div class="alert alert-success">
  <strong>Success!</strong> <a href="" target="blank" class="alert-link">Click Here To Print Labels</a>.
                <?php header( "refresh:30;url=$us_url_root./users" ); ?>
<!-- End of main content section -->
</div> <!-- /.col -->
</div> <!-- /.row -->
</div> <!-- /.container -->
</div> <!-- /.wrapper -->
Remove the refresh URL and try to find out if there are any errors. Do a dump on $file to see what is shown.

Hi Brandin,

Thanks for the quick response, I already tried to dump $file and it gives me the correct name. It doesn't get as far the as the refresh URL but I just removed it and tried to check and its the same.
I'm still trying to get this to work, i'm guessing it is something to do with composer as if I remove the composer parts of this script then everything else works and I can download the file.

I know that there was some big changes if anyone is good with composer the help would be great so I can figure out whats causing it to fail.
Unfortunately I'm terrible with composer. Have you tried removin the package and readding it? Also I would suggest checking the F12 Developer Tools Menu to watch the Network as you hit the page and it completes the upload (unless the server does this on the clients behalf...?)
Thanks I have tried re-adding it but i'm not getting any joy Sad

Forum Jump:

Users browsing this thread: 1 Guest(s)