× This forum is read only. As of July 23, 2019, the UserSpice forums have been closed. To receive support, please join our Discord by clicking here. Thank you!

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Old version of jq etc
#1
Hi,

I used userspice 4.3 and met with the issue that it conflicts with other components i used on my pages.

I meant jq version and some css files for example datatables.css
So i had to make some manual changes... it is ok for me but please update all libraries to the last version in userspice 4.4

Regards, Eugene
  Reply
#2
Can you tell me what kind of conflicts you had? One of the issues we run into is that there is no magically compatible version of things like jquery and bootstrap. If you update to bootstrap 4, you lose a lot of classes and glypgicons. Bootstrap 3 is missing other things. Upgrading from font awesome 4.7 to 5.0 breaks literally everything

One of the great things is that in UserSpice 4.4, these things are handled by the template so you can literally copy an existing template to a new folder and edit the includes to your heart's content.
  Reply
#3
I use UserSpice on the pages with different reports and I met with the issue with the sort signs in headers in dataTables.
The solution - I change the datatables.css with the new version from https://datatables.net/download/ and created my version of header.php where in line 165 changed the jquery version to 3.3.1
It solved all my problem.
  Reply
#4
Awesome. Glad to hear that. When I ran into that issue it was more of a conflict between 2 js includes. I wound up including a bundled version of bootstrap 4's js and it got it all sorted. Can you tell me what template you're on?
  Reply
#5
I am not sure I understood your question.
I don't use any template - I use a reporting framework koolreport.

And i decided not to use bootstrap 4 their - too many other issues.
  Reply
#6
Oh.. I meet this issue again. Bootstrap Select component works nicely without userspice and does not work with it.
Maybe you know the reason.

Also, I notice that my manual header.php is not used the userspcie continues to use the file from users folder.
Could you tell me please where exactly do I have to put my header.php that it will be used?
  Reply
#7
UserSpice 4.3 you would update header.php in users/includes.

UserSpice 4.4 you would check users/includes/template/prep.php to see the files that are included. Generally they will use the 3 header files and one from the template in usersc.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)