• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Updating to 4.4.03
#1
Tried this on my development system (which is running 4.4.02 fine) and got the error in the screenshot.

   

PHP error log says:


Code:
[03-Mar-2019 07:08:50 UTC] PHP Fatal error:  require_once(): Failed opening required 'C:/wamp64/www/stock/usersc/vendor/autoload.php' (include_path='.;C:\php\pear') in C:\wamp64\www\stock\users\helpers\helpers.php on line 35
[03-Mar-2019 07:08:50 UTC] PHP Stack trace:
[03-Mar-2019 07:08:50 UTC] PHP   1. {main}() C:\wamp64\www\stock\users\update.php:0
[03-Mar-2019 07:08:50 UTC] PHP   2. require_once() C:\wamp64\www\stock\users\update.php:2
[03-Mar-2019 07:08:50 UTC] PHP   3. require_once() C:\wamp64\www\stock\users\init.php:23

Tried just copying "vendor" folder to usersc - which is where it is looking for "autoload.php", but that just makes thing worse, PHP error log below:
===================================
[03-Mar-2019 07:26:22 UTC] PHP Fatal error: Cannot redeclare composerRequire09fae17662c0d8fcca874043515d9423() (previously declared in C:\wamp64\www\stock\users\vendor\composer\autoload_real.php:63) in C:\wamp64\www\stock\usersc\vendor\composer\autoload_real.php on line 70
[03-Mar-2019 07:26:22 UTC] PHP Stack trace:
[03-Mar-2019 07:26:22 UTC] PHP 1. {main}() C:\wamp64\www\stock\index.php:0
[03-Mar-2019 07:26:22 UTC] PHP 2. require_once() C:\wamp64\www\stock\index.php:3
[03-Mar-2019 07:26:22 UTC] PHP 3. require_once() C:\wamp64\www\stock\users\init.php:23
[03-Mar-2019 07:26:22 UTC] PHP 4. require_once() C:\wamp64\www\stock\users\helpers\helpers.php:35
====================================

Time to pop back to a backup!
  Reply
#2
Hi gnome,

You can do one of two things, remove the call to usersc/vendor/autoload from the helpers/helpers.php file or you can add the composer to usersc using ths package:
https://github.com/mudmin/updates/raw/ma...%20Fix.zip

Thank you,
Brandin.
  Reply
#3
(03-03-2019, 12:02 PM)Brandin Wrote: Hi gnome,

You can do one of two things, remove the call to usersc/vendor/autoload from the helpers/helpers.php file or you can add the composer to usersc using ths package:
https://github.com/mudmin/updates/raw/ma...%20Fix.zip

Thank you,
Brandin.

Thanks for the prompt response.

I'll go for the 4403 fix since I assume that will keep my install supported...

Cheers

Chris
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)