• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
v4.4.07: [SOLVED] loads of warning and notices while adding a user level
#1
Code:
[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]588[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]589[/b]

[b]Warning[/b]: include(/var/TFH/users/lang/.php): failed to open stream: No such file or directory in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Warning[/b]: include(): Failed opening '/var/TFH/users/lang/.php' for inclusion (include_path='.:/usr/share/php') in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]588[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]589[/b]

[b]Warning[/b]: include(/var/TFH/users/lang/.php): failed to open stream: No such file or directory in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Warning[/b]: include(): Failed opening '/var/TFH/users/lang/.php' for inclusion (include_path='.:/usr/share/php') in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]588[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]589[/b]

[b]Warning[/b]: include(/var/TFH/users/lang/.php): failed to open stream: No such file or directory in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Warning[/b]: include(): Failed opening '/var/TFH/users/lang/.php' for inclusion (include_path='.:/usr/share/php') in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]588[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]589[/b]

[b]Warning[/b]: include(/var/TFH/users/lang/.php): failed to open stream: No such file or directory in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Warning[/b]: include(): Failed opening '/var/TFH/users/lang/.php' for inclusion (include_path='.:/usr/share/php') in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]588[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]589[/b]

[b]Warning[/b]: include(/var/TFH/users/lang/.php): failed to open stream: No such file or directory in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Warning[/b]: include(): Failed opening '/var/TFH/users/lang/.php' for inclusion (include_path='.:/usr/share/php') in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]588[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]589[/b]

[b]Warning[/b]: include(/var/TFH/users/lang/.php): failed to open stream: No such file or directory in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Warning[/b]: include(): Failed opening '/var/TFH/users/lang/.php' for inclusion (include_path='.:/usr/share/php') in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]588[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]589[/b]

[b]Warning[/b]: include(/var/TFH/users/lang/.php): failed to open stream: No such file or directory in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Warning[/b]: include(): Failed opening '/var/TFH/users/lang/.php' for inclusion (include_path='.:/usr/share/php') in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]588[/b]

[b]Notice[/b]: Undefined index: THIS_CODE in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]589[/b]

[b]Warning[/b]: include(/var/TFH/users/lang/.php): failed to open stream: No such file or directory in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

[b]Warning[/b]: include(): Failed opening '/var/TFH/users/lang/.php' for inclusion (include_path='.:/usr/share/php') in [b]/var/TFH/users/helpers/us_helpers.php[/b] on line [b]612[/b]

Fresh install of 4.4.07 (not updated from previous versions). This does not not look normal .. or is it?
Secondary questions, is this the right place to put these issues (even if they may be classified as non-critical) if not feel free to delete the post and redirect me in the right place
ERROR: Root device mounted successfully, but /sbin/init does not exist.
Bailing out, you are on your own. Good luck!
  Reply
#2
This would be related to language, you need to make sure you run the updates script, fresh installs do not always have the most recent database.
  Reply
#3
(04-10-2019, 01:36 PM)Brandin Wrote: This would be related to language, you need to make sure you run the updates script, fresh installs do not always have the most recent database.

Version of reference is 4.4.07 and it was installed from the latest package you provide.

Code:
users/admin.php?view=updates
is saying that I am running the latest version, You are saying I should run an update on that version? which update would I use?
ERROR: Root device mounted successfully, but /sbin/init does not exist.
Bailing out, you are on your own. Good luck!
  Reply
#4
Database updates are different from version updates. You need to run the Database Updater. Go to yourdomain.com/users/update.php.
  Reply
#5
(04-10-2019, 03:42 PM)Brandin Wrote: Database updates are different from version updates. You need to run the Database Updater. Go to yourdomain.com/users/update.php.

I get:


Code:
Finished applying 0 updates (0 errors).

[url=http://tfh.local/users/admin.php]Return to the Admin Dashboard[/url]

a mysql query "select * from updates;" gives:

Code:
+----+--------------+---------------------+----------------+
| id | migration    | applied_on          | update_skipped |
+----+--------------+---------------------+----------------+
| 15 | 1XdrInkjV86F | 2018-02-18 22:33:24 |           NULL |
| 16 | 3GJYaKcqUtw7 | 2018-04-25 17:51:08 |           NULL |
| 17 | 3GJYaKcqUtz8 | 2018-04-25 17:51:08 |           NULL |
| 18 | 69qa8h6E1bzG | 2018-04-25 17:51:08 |           NULL |
| 19 | 2XQjsKYJAfn1 | 2018-04-25 17:51:08 |           NULL |
| 20 | 549DLFeHMNw7 | 2018-04-25 17:51:08 |           NULL |
| 21 | 4Dgt2XVjgz2x | 2018-04-25 17:51:08 |           NULL |
| 22 | VLBp32gTWvEo | 2018-04-25 17:51:08 |           NULL |
| 23 | Q3KlhjdtxE5X | 2018-04-25 17:51:08 |           NULL |
| 24 | ug5D3pVrNvfS | 2018-04-25 17:51:08 |           NULL |
| 25 | 69FbVbv4Jtrz | 2018-04-25 17:51:09 |           NULL |
| 26 | 4A6BdJHyvP4a | 2018-04-25 17:51:09 |           NULL |
| 27 | 37wvsb5BzymK | 2018-04-25 17:51:09 |           NULL |
| 28 | c7tZQf926zKq | 2018-04-25 17:51:09 |           NULL |
| 29 | ockrg4eU33GP | 2018-04-25 17:51:09 |           NULL |
| 30 | XX4zArPs4tor | 2018-04-25 17:51:09 |           NULL |
| 31 | pv7r2EHbVvhD | 2018-04-26 01:00:00 |           NULL |
| 32 | uNT7NpgcBDFD | 2018-04-26 01:00:00 |           NULL |
| 33 | mS5VtQCZjyJs | 2018-12-11 14:19:16 |           NULL |
| 34 | 23rqAv5elJ3G | 2018-12-11 14:19:51 |           NULL |
| 35 | hcA5B3PLhq6E | 2019-04-09 16:55:35 |           NULL |
| 36 | FyMYJ2oeGCTX | 2019-04-09 16:55:35 |           NULL |
| 37 | iit5tHSLatiS | 2019-04-09 16:55:35 |           NULL |
| 38 | VNEno3E4zaNz | 2019-04-09 16:55:35 |           NULL |
| 39 | qPEARSh49fob | 2019-04-09 16:55:35 |           NULL |
| 40 | 2ZB9mg1l0JXe | 2019-04-09 16:55:35 |           NULL |
| 41 | B9t6He7qmFXa | 2019-04-09 16:55:35 |           NULL |
| 42 | 86FkFVV4TGRg | 2019-04-09 16:55:35 |           NULL |
| 43 | y4A1Y0u9n2Rt | 2019-04-09 16:55:35 |           NULL |
| 44 | Tm5xY22MM8eC | 2019-04-09 16:55:35 |           NULL |
+----+--------------+---------------------+----------------+
ERROR: Root device mounted successfully, but /sbin/init does not exist.
Bailing out, you are on your own. Good luck!
  Reply
#6
Hi there,

It does look like all of the updates have been applied. The errors you are receiving are related to the new multilanguage system. I'm not 100% positive on how it works as Dan coded that, but its possible there could be a session related issue or something of the such. I will send this over to him to take a look at.

Brandin.
  Reply
#7
Hi, I have similar issues after upgrade - and can confirm the database has updated..
[11-Apr-2019 06:18:27 UTC] PHP Notice: Undefined index: THIS_CODE in /users/helpers/us_helpers.php on line 588
[11-Apr-2019 06:18:27 UTC] PHP Stack trace:
[11-Apr-2019 06:18:27 UTC] PHP 1. {main}() /html/users/admin.php:0
[11-Apr-2019 06:18:27 UTC] PHP 2. include() /html/users/admin.php:231
[11-Apr-2019 06:18:27 UTC] PHP 3. Validate->check() /html/usersc/includes/admin/_admin_user.php:155
[11-Apr-2019 06:18:27 UTC] PHP 4. lang() /html/users/classes/Validate.php:58
[11-Apr-2019 06:18:27 UTC] PHP Notice: Undefined index: THIS_CODE in /html/users/helpers/us_helpers.php on line 589
[11-Apr-2019 06:18:27 UTC] PHP Stack trace:
[11-Apr-2019 06:18:27 UTC] PHP 1. {main}() /html/users/admin.php:0
[11-Apr-2019 06:18:27 UTC] PHP 2. include() /html/users/admin.php:231
[11-Apr-2019 06:18:27 UTC] PHP 3. Validate->check() /html/usersc/includes/admin/_admin_user.php:155
[11-Apr-2019 06:18:27 UTC] PHP 4. lang() /html/users/classes/Validate.php:58
[11-Apr-2019 06:18:27 UTC] PHP Warning: include(/html/users/lang/.php): failed to open stream: No such file or directory in /html/users/helpers/us_helpers.php on line 612
  Reply
#8
I need more information on your setup please, as I requested above.
  Reply
#9
Issue is resolved as per 4.4.09

Cheers
ERROR: Root device mounted successfully, but /sbin/init does not exist.
Bailing out, you are on your own. Good luck!
  Reply
#10
Awesome to hear. Thank you for letting us know.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)