• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
e-mail not verifying
#21
Ah yes, that does make sense Smile Thanks!

However...the details are not showing up in the e-mail that is sent to me.

I have this:

<p>You just got a new user on <?=$sitename?>.</p>
<p>First name:<?=$fname?></p>
<p>Last name: <?=$lname?></p>
<p>e-Mail: <?=$email?></p>
<p>

$params = array(
'sitename' => $settings->site_name,
'fname' => $userdetails->fname,
'lname' => $userdetails->lname,
'email' => rawurlencode($userdetails->email),
);
  Reply
#22
Is this...
$params = array(
'sitename' => $settings->site_name,
'fname' => $userdetails->fname,
'lname' => $userdetails->lname,
'email' => rawurlencode($userdetails->email),
);

In the view in the usersc/scripts/during_user_creation?
  Reply
#23
yes, and the other bit is in the _email_newuser.php

the whole thing:

$params = array(
'sitename' => $settings->site_name,
'fname' => $userdetails->fname,
'lname' => $userdetails->lname,
'email' => rawurlencode($userdetails->email),
);
$to = rawurlencode("my@email.com");
$subject = 'New Registration!';
$body = email_body('_email_newuser.php',$params);
email($to,$subject,$body);
  Reply
#24
Did you happen to have an idea why the above wont give me any of the details in that mail?
  Reply
#25
Sorry. I've been out of the office and will be a good bit this week. Before you call that function can you do
dnd($userdetails); to make sure that variable is set properly?
  Reply
#26
Like this?

dnd($userdetails);
$params = array(
'sitename' => $settings->site_name,
'fname' => $userdetails->fname,
'lname' => $userdetails->lname,
'email' => rawurlencode($userdetails->email),
);
$to = rawurlencode("my@email.com");
$subject = 'New Registration!';
$body = email_body('_email_newuser.php',$params);
email($to,$subject,$body);
  Reply
#27
yes
  Reply
#28
when i send the registration form it does go into the database, but the page says :

Notice: Undefined variable: userdetails in /www/usersc/scripts/during_user_creation.php on line 28

NULL

Line 28 being that line we just added.

And only the registrant gets an email.

$db->update('users',$theNewId,['phone'=>Input::get('phone')]);
$db->update('users',$theNewId,['challenges'=>Input::get('challenges')]);
$db->update('users',$theNewId,['membership'=>Input::get('membership')]);
$db->update('users',$theNewId,['orig_chos_day'=>Input::get('orig_chos_day')]);
$db->update('users',$theNewId,['message'=>Input::get('message')]);
$db->update('users',$theNewId,['ecname'=>Input::get('ecname')]);
$db->update('users',$theNewId,['ecphone'=>Input::get('ecphone')]);

dnd($userdetails);

$params = array(
'sitename' => $settings->site_name,
'fname' => $userdetails->fname,
'lname' => $userdetails->lname,
'email' => rawurlencode($userdetails->email),
'phone' => $userdetails->phone,
);
$to = rawurlencode("my@mail.com");
$subject = 'New Registration!';
$body = email_body('_email_newuser.php',$params);
email($to,$subject,$body);
  Reply
#29
Hope you had a nice trip Mudmin Smile

Did you happen to have an idea what is causing this?
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)